Sophos Web Appliance 4.2.1.3 information Remote Code Execution Vulnerability

Summary

an issue in which users can block or unblock an IP address in a quarantine policy and inject a shell command

Credit:

The information has been provided by Russell Sanford.
The original article can be found at: http://www.securityfocus.com/bid/95853


Details

Vulnerable Systems:
 * Sophos Web Appliance 4.2.1.3

The Sophos Web Appliance (version 4.2.1.3) is vulnerable to two Remote Command Injection vulnerabilities affecting its web administrative interface. These vulnerabilities occur in the MgrReport.php (/controllers/MgrReport.php) component responsible for blocking and unblocking IP addresses from accessing the device. The device doesn’t properly escape the information passed in the variables ‘unblockip’ and ‘blockip’ before calling the shell_exec() function which allows for system commands to be injected into the device. The code erroneously suggests that the information handled is protected by utilizing the variable name ‘escapedips’ – however this was not the case. The Sophos ID is NSWA-1258.

CVE Information:
CVE-2016-9553

Disclosure Timeline:
Publish Date : 2017-01-28
Last Update Date : 2017-03-08

Categories: News