Invision Power Board ‘search.php’ Cross Site Scripting Vulnerability

Summary

Invision Power Board is prone to a cross-site scripting vulnerability because it fails to sanitize user-supplied input.

Credit:

The original article can be found at: http://www.securityfocus.com/bid/54403


Details

Vulnerable Systems:
 *Invision Power Services Invision Power Board 3.3.1 and prior

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and launch other attacks.
Invision Power Board versions 3.2.x and 3.3.0 through 3.3.3 are vulnerable.

Vendor Status:
Currently we are not aware of any vendor-supplied patches

Disclosure Timeline:
Initial Release: Jul 11 2012

Categories: News