Joomla! Simple SWFUpload Component ‘uploadhandler.php’ Arbitrary File Upload Vulnerability

Summary

The Simple SWFUpload component for Joomla! is prone to a vulnerability that lets attackers upload arbitrary files because the application fails to adequately sanitize user-supplied input.

Credit:

The original article can be found at: http://www.securityfocus.com/bid/53968
The information has been provided by Sammy FORGIT.


Details

Vulnerable Systems:
 * Simple SWFUpload 2.0

An attacker can exploit this vulnerability to upload arbitrary code and run it in the context of the web server process. This may facilitate unauthorized access or privilege escalation; other attacks are also possible.

Vendor Status:Disclosure Timeline:
Initial Release : Jun 12 2012

Categories: News