WordPress Gallery Plugin Arbitrary File Upload Vulnerability

Summary

The Gallery plugin for WordPress is prone to a vulnerability that lets attackers upload arbitrary files. The issue occurs because the application fails to adequately sanitize user-supplied input.

Credit:

The information has been provided by Sammy FORGIT.
The original article can be found at: http://www.securityfocus.com/bid/53849


Details

Vulnerable Systems:
 * WordPress Gallery Plugin 3.06

An attacker may leverage this issue to upload arbitrary files to the affected computer; this can result in arbitrary code execution within the context of the vulnerable application.

Vendor Status:
An update had been issued for this vulnerability

Patch Availability:
http://wordpress.org/extend/plugins/gallery-plugin/

Disclosure Timeline:
Initial Release: Jun 07 2012

Categories: News