Apache Airflow versions 1.10.10 Deserialization of Untrusted Data Vulnerability

Summary

An issue was found in Apache Airflow versions 1.10.10 and below.

Credit:

The information has been provided by Ash Berlin-Taylor

The original article can be found at:https://lists.apache.org/thread.html/r7255cf0be3566f23a768e2a04b40fb09e52fcd1872695428ba9afe91%40%3Cusers.airflow.apache.org%3E


Details

When using CeleryExecutor, if an attack can connect to the broker (Redis, RabbitMQ) directly, it was possible to insert a malicious payload directly to the broker which could lead to a deserialization attack (and thus remote code execution) on the Worker.

 

Vulnerable Systems:

Apache Airflow versions 1.10.10

 

CVE Information:

CVE-2020-11982

 

Disclosure Timeline:
Published Date:7/16/2020

Categories: FeaturedNews