Apache Airflow versions 1.10.10 Improper Neutralization of Input During Web Page Generation (‘Cross-site Scripting’) Vulnerability

Summary

Apache Airflow versions 1.10.10 suffers from improper neutralization of input during Web page generation (‘Cross-site Scripting’) vulnerability

Credit:

The information has been provided by Ash Berlin-Taylor

The original article can be found at:https://lists.apache.org/thread.html/r7255cf0be3566f23a768e2a04b40fb09e52fcd1872695428ba9afe91%40%3Cusers.airflow.apache.org%3E


Details

An issue was found in Apache Airflow versions 1.10.10 and below. A stored XSS vulnerability was discovered in the Chart pages of the the “classic” UI.

 

Vulnerable Systems:

Apache Airflow versions 1.10.10

 

CVE Information:

CVE-2020-9485

 

Disclosure Timeline:
Published Date:7/16/2020

Categories: FeaturedNews