Apache Tomcat 10.0.0-M1 to 10.0.0-M6 Improper Restriction of Operations within the Bounds of a Memory Buffer Vulnerability

Summary

Apache Tomcat 10.0.0-M1 to 10.0.0-M6 suffers from improper restriction of operations within the bounds of a memory buffer vulnerability

Credit:

The information has been provided by Markus Koschany

The original article can be found at:https://lists.apache.org/thread.html/r61f411cf82488d6ec213063fc15feeeb88e31b0ca9c29652ee4f962e%40%3Cannounce.tomcat.apache.org%3E


Details

An h2c direct connection to Apache Tomcat 10.0.0-M1 to 10.0.0-M6, 9.0.0.M5 to 9.0.36 and 8.5.1 to 8.5.56 did not release the HTTP/1.1 processor after the upgrade to HTTP/2. If a sufficient number of such requests were made, an OutOfMemoryException could occur leading to a denial of service.

 

Vulnerable Systems:

Apache Tomcat 10.0.0-M1 to 10.0.0-M6

Apache Tomca 9.0.0.M5 to 9.0.36 

Apache Tomca 8.5.1 to 8.5.56

 

CVE Information:

CVE-2020-13934

 

Disclosure Timeline:
Published Date:7/14/2020

Categories: FeaturedNews