Artifex Ghostscript 9.50 Improper Restriction of Operations within the Bounds of a Memory Buffer Vulnerability

Summary

Artifex Ghostscript 9.50 suffers from improper restriction of operations within the bounds of a memory buffer vulnerability

Credit:

The information has been provided by Ray Johnston

The original article can be found at:http://git.ghostscript.com/?p=ghostpdl.git;a=log


Details

A memory corruption issue was found in Artifex Ghostscript 9.50 and 9.52. Use of a non-standard PostScript operator can allow overriding of file access controls. The ‘rsearch’ calculation for the ‘post’ size resulted in a size that was too large, and could underflow to max uint32_t. This was fixed in commit 5d499272b95a6b890a1397e11d20937de000d31b.

 

Vulnerable Systems:

Artifex Ghostscript 9.50 

Artifex Ghostscript 9.52

 

CVE Information:

CVE-2020-15900

 

Disclosure Timeline:
Published Date:7/28/2020

Categories: News