Barco ClickShare Huddle CS-100 devices before 1.9.0 Other Vulnerability

Summary

Barco ClickShare Huddle CS-100 devices before 1.9.0 and CSE-200 devices before 1.9.0 have incorrect Credentials Management. 

Credit:

The information has been provided by Vendor

The original article can be found at:https://www.barco.com/en/clickshare/firmware-update


Details

The ClickShare Base Unit implements encryption at rest using encryption keys which are shared across all ClickShare Base Units of models CS-100 & CSE-200.

 

Vulnerable Systems:

Barco ClickShare Huddle CS-100 devices before 1.9.0

Barco ClickShare Huddle CSE-200 devices before 1.9.0

 

CVE Information:

CVE-2019-18825

 

Disclosure Timeline:
Published Date:12/17/2019

Categories: News