Cherokee 0.4.27 to 1.2.104 NULL Pointer Dereference Vulnerability

Summary

Cherokee 0.4.27 to 1.2.104 suffers from nll pointer dereference vulnerability

Credit:

The information has been provided by Vendor

The original article can be found at:http://cherokee-project.com/downloads.html


Details

Cherokee 0.4.27 to 1.2.104 is affected by a denial of service due to a NULL pointer dereferences. A remote unauthenticated attacker can crash the server by sending an HTTP request to protected resources using a malformed Authorization header that is mishandled during a cherokee_buffer_add call within cherokee_validator_parse_basic or cherokee_validator_parse_digest.

 

Vulnerable Systems:

Cherokee 0.4.27 to 1.2.104

 

CVE Information:

CVE-2020-12845

 

Disclosure Timeline:
Published Date:7/27/2020

Categories: News