D-Link DAP-1860 devices before v1.04b03 Beta Improper Authentication Vulnerability

Summary

D-Link DAP-1860 devices before v1.04b03 Beta allow access to administrator functions without authentication via the HNAP_AUTH header timestamp value. 

Credit:

The information has been provided by Vendor

The original article can be found at:https://chung96vn.wordpress.com/2019/11/15/d-link-dap-1860-vulnerabilities/


Details

In HTTP requests, part of the HNAP_AUTH header is the timestamp used to determine the time when the user sent the request. If this value is equal to the value stored in the device’s /var/hnap/timestamp file, the request will pass the HNAP_AUTH check function.

 

Vulnerable Systems:

D-Link DAP-1860 devices before v1.04b03 Beta

 

CVE Information:

CVE-2019-19598

 

Disclosure Timeline:
Published Date:12/4/2019

Categories: FeaturedNews