Glyphandcog Xpdfreader 4.01.01 Denial Of Service Vulnerability

Summary

A stack-based buffer over-read exists in PostScriptFunction::transform in Function.cc in Xpdf 4.01.01 because GfxSeparationColorSpace and GfxDeviceNColorSpace mishandle tint transform functions. It can, for example, be triggered by sending a crafted PDF document to the pdftops tool. It might allow an attacker to cause Denial of Service or leak memory data.

Credit:

The information has been provided by Mike Zhangis at: https://forum.xpdfreader.com/viewtopic.php?f=3&t=41806


Details

Glyphandcog Xpdfreader is prone to a denial of service (DoS) vulnerability.This allow a remote attacker to cause a denial of service (DoS) condition due to high consumption of system resources via certain vulnerable vectors.

 

Vulnerable Systems:

  • Glyphandcog Xpdfreader 4.01.01

CVE Information:

CVE-2019-12493

Disclosure Timeline:
Publish Date:05/30/2019

Categories: News