Glyphandcog Xpdfreader 4.01.01 “FlateStream::getChar()” Denial Of Service Vulnerability

Summary

There is an out-of-bounds read vulnerability in the function FlateStream::getChar() located at Stream.cc in Xpdf 4.01.01. It can, for example, be triggered by sending a crafted PDF document to the pdftoppm tool. It might allow an attacker to cause Information Disclosure or a denial of service.

Credit:

The information has been provided by PanguL4b

The original article can be found at: https://github.com/PanguL4b/pocs/tree/master/xpdf/out-of-bounds-read-in-FlateStream__getChar


Details

Glyphandcog Xpdfreader  is prone to a denial of service (DoS) vulnerability.This allow a remote attacker to cause a denial of service (DoS) condition due to high consumption of system resources via certain vulnerable vectors. 

Vulnerable Systems:

  • Glyphandcog Xpdfreader 4.01.01

CVE Information:

CVE-2019-12515

Disclosure Timeline:
Publish Date:06/01/2019

Categories: News