HHVM versions prior to 3.30.12 Improper Restriction of Operations within the Bounds of a Memory Buffer Vulnerability

Summary

HHVM versions prior to 3.30.12 suffers from improper restriction of operations within the bounds of a memory buffer vulnerability.

Credit:

The information has been provided by Vendor

The original article can be found at:https://hhvm.com/blog/2019/10/28/security-update.html


Details

Various APC functions accept keys containing null bytes as input, leading to premature truncation of input. This issue affects HHVM versions prior to 3.30.12, all versions between 4.0.0 and 4.8.5, all versions between 4.9.0 and 4.23.1, as well as 4.24.0, 4.25.0, 4.26.0, 4.27.0, 4.28.0, and 4.28.1.

 

Vulnerable Systems:

HHVM versions prior to 3.30.12

HHVM versions all versions between 4.0.0 and 4.8.5

HHVM versions all versions between 4.9.0 and 4.23.1

HHVM versions 4.24.0

HHVM versions 4.25.0

HHVM versions 4.26.0

HHVM versions 4.27.0

HHVM versions 4.28.0

HHVM versions 4.28.1

 

CVE Information:

CVE-2019-11936

 

Disclosure Timeline:
Published Date:12/4/2019

Categories: News