HUAWEI Mate 20 smartphones versions 10.1.0.160 Improper Authentication Vulnerability

Summary

HUAWEI Mate 20 smartphones with versions earlier than 10.1.0.160(C00E160R2P11) have an improper authorization vulnerability.

Credit:

The information has been provided by Ding Yicong

The original article can be found at:https://www.huawei.com/en/psirt/security-advisories/huawei-sa-20200722-02-smartphone-en


Details

The software does not properly restrict certain operation in certain scenario, the attacker should do certain configuration before the user turns on student mode function. Successful exploit could allow the attacker to bypass the limit of student mode function. Affected product versions include: HUAWEI Mate 20 versions Versions earlier than 10.1.0.160(C00E160R3P8).

 

Vulnerable Systems:

HUAWEI Mate 20 smartphones versions 10.1.0.160

 

CVE Information:

CVE-2020-9251

 

Disclosure Timeline:
Published Date:7/27/2020

Categories: FeaturedNews