HUAWEI Mate 30 with versions earlier than 10.1.0.150 Access of Resource Using Incompatible Type (‘Type Confusion’) Vulnerability

Summary

HUAWEI Mate 30 with versions earlier than 10.1.0.150(C00E136R5P3) have a type confusion vulnerability.

Credit:

The information has been provided by Vendor

The original article can be found at:https://www.huawei.com/en/psirt/security-advisories/huawei-sa-20200701-05-smartphone-en


Details

The system does not properly check and transform the type of certain variable, the attacker tricks the user into installing then running a crafted application, successful exploit could cause code execution.

 

Vulnerable Systems:

HUAWEI Mate 30 with versions earlier than 10.1.0.150

 

CVE Information:

CVE-2020-9261

 

Disclosure Timeline:
Published Date:7/6/2020

Categories: FeaturedNews