HUAWEI P30 with versions earlier than 10.1.0.160 Exposure of Sensitive Information to an Unauthorized Actor Vulnerability

Summary

HUAWEI P30 with versions earlier than 10.1.0.160(C00E160R2P11) and HUAWEI P30 Pro with versions earlier than 10.1.0.160(C00E160R2P8) have an information disclosure vulnerability.

Credit:

The information has been provided by ZhengYuwei

The original article can be found at:https://www.huawei.com/en/psirt/security-advisories/huawei-sa-20200624-01-smartphone-en


Details

HUAWEI P30 with versions earlier than 10.1.0.160(C00E160R2P11) and HUAWEI P30 Pro with versions earlier than 10.1.0.160(C00E160R2P8) have an information disclosure vulnerability. Certain function’s default configuration in the system seems insecure, an attacker should craft a WI-FI hotspot to launch the attack. Successful exploit could cause information disclosure.

 

Vulnerable Systems:

HUAWEI P30 with versions earlier than 10.1.0.160 

HUAWEI P30 Pro with versions earlier than 10.1.0.160

 

CVE Information:

CVE-2020-1836

 

Disclosure Timeline:
Published Date:7/6/2020

Categories: FeaturedNews