Juniper Networks Junos OS 12.3 Improper Neutralization of Input During Web Page Generation (‘Cross-site Scripting’) Vulnerability

Summary

Juniper Networks Junos OS 12.3 suffers from improper neutralization of input during web page generation (‘Cross-site Scripting’) vulnerability

Credit:

The information has been provided by Vendor

The original article can be found at:https://kb.juniper.net/JSA10986


Details

Insufficient Cross-Site Scripting (XSS) protection in J-Web may potentially allow a remote attacker to inject web script or HTML, hijack the target user’s J-Web session and perform administrative actions on the Junos device as the targeted user. This issue affects Juniper Networks Junos OS 12.3 versions prior to 12.3R12-S15; 12.3X48 versions prior to 12.3X48-D86, 12.3X48-D90 on SRX Series; 14.1X53 versions prior to 14.1X53-D51 on EX and QFX Series; 15.1F6 versions prior to 15.1F6-S13; 15.1 versions prior to 15.1R7-S5; 15.1X49 versions prior to 15.1X49-D181, 15.1X49-D190 on SRX Series; 15.1X53 versions prior to 15.1X53-D238 on QFX5200/QFX5110 Series; 15.1X53 versions prior to 15.1X53-D592 on EX2300/EX3400 Series; 16.1 versions prior to 16.1R4-S13, 16.1R7-S5; 16.2 versions prior to 16.2R2-S10; 17.1 versions prior to 17.1R2-S11, 17.1R3-S1; 17.2 versions prior to 17.2R1-S9, 17.2R3-S2; 17.3 versions prior to 17.3R2-S5, 17.3R3-S5; 17.4 versions prior to 17.4R2-S6, 17.4R3; 18.1 versions prior to 18.1R3-S7; 18.2 versions prior to 18.2R2-S5, 18.2R3; 18.3 versions prior to 18.3R1-S6, 18.3R2-S1, 18.3R3; 18.4 versions prior to 18.4R1-S5, 18.4R2; 19.1 versions prior to 19.1R1-S2, 19.1R2.

 

Vulnerable Systems:

Juniper Networks Junos OS 12.3 versions prior to 12.3R12-S15

Juniper Networks Junos OS 12.3X48 versions prior to 12.3X48-D86

Juniper Networks Junos OS 12.3X48-D90 on SRX Series

Juniper Networks Junos OS 14.1X53 versions prior to 14.1X53-D51

Juniper Networks Junos OS 15.1F6 versions prior to 15.1F6-S13

Juniper Networks Junos OS 15.1 versions prior to 15.1R7-S5

Juniper Networks Junos OS 15.1X49 versions prior to 15.1X49-D181

Juniper Networks Junos OS 15.1X49-D190 on SRX Series

Juniper Networks Junos OS 15.1X53 versions prior to 15.1X53-D238 

Juniper Networks Junos OS 15.1X53 versions prior to 15.1X53-D592 

Juniper Networks Junos OS 16.1 versions prior to 16.1R4-S13

Juniper Networks Junos OS 16.1R7-S5

Juniper Networks Junos OS 16.2 versions prior to 16.2R2-S10

Juniper Networks Junos OS 17.1 versions prior to 17.1R2-S11

Juniper Networks Junos OS 17.1R3-S1

Juniper Networks Junos OS 17.2 versions prior to 17.2R1-S9

Juniper Networks Junos OS 17.2R3-S2

Juniper Networks Junos OS 17.3 versions prior to 17.3R2-S5

Juniper Networks Junos OS 17.3R3-S5

Juniper Networks Junos OS 17.4 versions prior to 17.4R2-S6

Juniper Networks Junos OS 17.4R3

Juniper Networks Junos OS 18.1 versions prior to 18.1R3-S7

Juniper Networks Junos OS 18.2 versions prior to 18.2R2-S5

Juniper Networks Junos OS 18.2R3

Juniper Networks Junos OS 18.3 versions prior to 18.3R1-S6

Juniper Networks Junos OS 18.3R2-S1

Juniper Networks Junos OS 18.3R3

Juniper Networks Junos OS 18.4 versions prior to 18.4R1-S5

Juniper Networks Junos OS 18.4R2

Juniper Networks Junos OS 19.1 versions prior to 19.1R1-S2

Juniper Networks Junos OS 19.1R2

 

CVE Information:

CVE-2020-1607

 

Disclosure Timeline:
Published Date:1/15/2020

Categories: News