Linux kernel 4.4.x before 4.4.195 NULL Pointer Dereference Vulnerability

Summary

Linux kernel 4.4.x before 4.4.195 suffers from null pointer dereference vulnerability

Credit:

The information has been provided by Mao Wenan

The original article can be found at:https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.4.195

 


Details

An issue was discovered in the Linux kernel 4.4.x before 4.4.195. There is a NULL pointer dereference in rds_tcp_kill_sock() in net/rds/tcp.c that will cause denial of service, aka CID-91573ae4aed0.

 

Vulnerable Systems:

Linux kernel 4.4.x before 4.4.195 

 

CVE Information:

CVE-2019-18680

Disclosure Timeline:
Published Date:11/4/2019