Linux kernel prior to mainline 5.3 Improper Input Validation Vulnerability

Summary

An exploitable denial-of-service vulnerability exists in the Linux kernel prior to mainline 5.3. An attacker could exploit this vulnerability by triggering AP to send IAPP location updates for stations before the required authentication process has completed. 

Credit:

The information has been provided by Mitchell Frank

The original article can be found at:https://talosintelligence.com/vulnerability_reports/TALOS-2019-0900


Details

This could lead to different denial-of-service scenarios, either by causing CAM table attacks, or by leading to traffic flapping if faking already existing clients in other nearby APs of the same wireless infrastructure. An attacker can forge Authentication and Association Request packets to trigger this vulnerability.

 

Vulnerable Systems:

Linux kernel prior to mainline 5.3

 

CVE Information:

CVE-2019-5108

 

Disclosure Timeline:
Published Date:12/23/2019

Categories: News