Magento 2.2 prior to 2.2.10 Cross-Site Request Forgery (CSRF) Vulnerability

Summary

An authenticated user can craft a malicious CSRF payload that can result in arbitrary command execution.

Credit:

The information has been provided by Blaklis

The original article can be found at:https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update

 


Details

A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can craft a malicious CSRF payload that can result in arbitrary command execution.

 

Vulnerable Systems:

Magento 2.2 prior to 2.2.10

Magento 2.3 prior to 2.3.3 or 2.3.2-p1. 

 

CVE Information:

CVE-2019-8109

 

Disclosure Timeline:
Published Date:11/5/2019