Magento 2.2 prior to 2.2.10 Improper Input Validation Vulnerability

Summary

An authenticated user can leverage plugin functionality that is related to email templates to manipulate the interceptor class in a way that allows a malicious user to execute arbitrary code.

 

 

Credit:

The information has been provided by Blaklis

The original article can be found at:https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update


Details

A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can leverage plugin functionality related to email templates to manipulate the interceptor class in a way that allows an attacker to execute arbitrary code.

 

Vulnerable Systems:

Magento 2.2 prior to 2.2.10

Magento 2.3 prior to 2.3.3 or 2.3.2-p1

 

CVE Information:

CVE-2019-8111

 

Disclosure Timeline:
Published Date:11/5/2019