Magento 2.2 prior to 2.2.10 Improper Input Validation Vulnerability

Summary

 An authenticated user with export data transfer privileges can craft a request that performs arbitrary file deletion.

Credit:

The information has been provided by crownpeanut

The original article can be found at:https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update

 


Details

An arbitrary file deletion vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with export data transfer privileges can craft a request to perform arbitrary file deletion.

 

Vulnerable Systems:

Magento 2.2 prior to 2.2.10

Magento 2.3 prior to 2.3.3 or 2.3.2-p1

 

CVE Information:

CVE-2019-8107

 

Disclosure Timeline:
Published Date:11/5/2019