Magento 2.2 prior to 2.2.10 Improper Neutralization of Input During Web Page Generation (‘Cross-site Scripting’) Vulnerability

Summary

An authenticated user can inject arbitrary JavaScript code through email template preview.

Credit:

The information has been provided by Edgar Boda-Majer

The original article can be found at:https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update

 


Details

A reflected cross-site scripting (XSS) vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can inject arbitrary JavaScript code via email template preview.

 

Vulnerable Systems:

Magento 2.2 prior to 2.2.10

Magento 2.3 prior to 2.3.3 or 2.3.2-p1

 

CVE Information:

CVE-2019-8092

Disclosure Timeline:
Published Date:11/5/2019