NGINX Controller versions 3.1.0-3.3.0 Insufficient Information Vulnerability

Summary

AVRD uses world-readable and world-writable permissions on its socket, which allows processes or users on the local system to write arbitrary data into the socket. A local system attacker can make AVRD segmentation fault (SIGSEGV) by writing malformed messages to the socket.

Credit:

The information has been provided by Vendor

The original article can be found at:https://support.f5.com/csp/article/K95120415


Details

On NGINX Controller versions 3.1.0-3.3.0, AVRD uses world-readable and world-writable permissions on its socket, which allows processes or users on the local system to write arbitrary data into the socket. A local system attacker can make AVRD segmentation fault (SIGSEGV) by writing malformed messages to the socket.

 

Vulnerable Systems:

NGINX Controller versions 3.1.0-3.3.0

 

CVE Information:

CVE-2020-5895

 

Disclosure Timeline:
Published Date:5/7/2020

Categories: FeaturedNews