SAP NetWeaver AS ABAP Business Server versions 700 Improper Neutralization of Input During Web Page Generation (‘Cross-site Scripting’) Vulnerability

Summary

SAP NetWeaver AS ABAP Business Server versions 700 suffers from improper neutralization of input during web page generation (‘Cross-site Scripting’) vulnerability

Credit:

The information has been provided by Vendor

The original article can be found at:https://wiki.scn.sap.com/wiki/pages/viewpage.action?pageId=547426775


Details

SAP NetWeaver AS ABAP Business Server Pages Test Application SBSPEXT_TABLE, versions 700, 701, 702, 730, 731, 740, 750, 751, 752, 753, 754, does not sufficiently encode user-controlled inputs, resulting in reflected Cross-Site Scripting (XSS) vulnerability.

 

Vulnerable Systems:

SAP NetWeaver AS ABAP Business Server versions 700

SAP NetWeaver AS ABAP Business Server versions 701

SAP NetWeaver AS ABAP Business Server versions 702

SAP NetWeaver AS ABAP Business Server versions 730

SAP NetWeaver AS ABAP Business Server versions 731

SAP NetWeaver AS ABAP Business Server versions 740

SAP NetWeaver AS ABAP Business Server versions 750

SAP NetWeaver AS ABAP Business Server versions 751

SAP NetWeaver AS ABAP Business Server versions 752

SAP NetWeaver AS ABAP Business Server versions 753

SAP NetWeaver AS ABAP Business Server versions 754

 

CVE Information:

CVE-2020-6246

Disclosure Timeline:
Published Date:6/10/2020

Categories: News