SAP Process Integration SAP_XIAF 7.31 Improper Neutralization of Input During Web Page Generation (‘Cross-site Scripting’) Vulnerability

Summary

SAP Process Integration SAP_XIAF 7.31 suffers from improper neutralization of input during web page generation (‘Cross-site Scripting’) vulnerability

Credit:

The information has been provided by Deniz Cevik

The original article can be found at:https://wiki.scn.sap.com/wiki/pages/viewpage.action?pageId=533671771


Details

PI Rest Adapter of SAP Process Integration (update provided in SAP_XIAF 7.31, 7.40, 7.50) does not sufficiently encode user-controlled inputs, resulting in Cross-Site Scripting (XSS) vulnerability.

 

Vulnerable Systems:

SAP Process Integration SAP_XIAF 7.31

SAP Process Integration SAP_XIAF 7.40

SAP Process Integration SAP_XIAF 7.50

 

CVE Information:

CVE-2020-6305

 

Disclosure Timeline:
Published Date:1/14/2020

Categories: FeaturedNews