Spring Cloud Config versions 2.2.x prior to 2.2.3 Improper Limitation of a Pathname to a Restricted Directory (‘Path Traversal’) Vulnerability

Summary

Spring Cloud Config, versions 2.2.x prior to 2.2.3, versions 2.1.x prior to 2.1.9, and older unsupported versions allow applications to serve arbitrary configuration files through the spring-cloud-config-server module.

Credit:

The information has been provided by Fei Lu

The original article can be found at:https://tanzu.vmware.com/security/cve-2020-5410


Details

A malicious user, or attacker, can send a request using a specially crafted URL that can lead to a directory traversal attack.

 

Vulnerable Systems:

Spring Cloud Config versions 2.2.x prior to 2.2.3

Spring Cloud Config versions 2.1.x prior to 2.1.9

 

CVE Information:

CVE-2020-5410

Disclosure Timeline:
Published Date:6/2/2020

Categories: FeaturedNews