TYPO3 before 8.7.30 Deserialization of Untrusted Data Vulnerability

Summary

An issue was discovered in TYPO3 before 8.7.30, 9.x before 9.5.12, and 10.x before 10.2.2. It has been discovered that the classes QueryGenerator and QueryView are vulnerable to insecure deserialization. 

Credit:

The information has been provided by Daniel Windloff 

The original article can be found at:https://review.typo3.org/q/%2522Resolves:+%252389005%2522+topic:security


Details

One exploitable scenario requires having the system extension ext:lowlevel (Backend Module: DB Check) installed, with a valid backend user who has administrator privileges. The other exploitable scenario requires having the system extension ext:sys_action installed, with a valid backend user who has limited privileges.

 

Vulnerable Systems:

TYPO3 before 8.7.30

TYPO3 9.x before 9.5.12

TYPO3 10.x before 10.2.2.

 

CVE Information:

CVE-2019-19849

 

Disclosure Timeline:
Published Date:12/17/2019

Categories: News