Zimbra before 8.8.15 Patch 10 Unrestricted Upload of File with Dangerous Type Vulnerability

Summary

Zimbra before 8.8.15 Patch 10 and 9.x before 9.0.0 Patch 3 allows remote code execution via an avatar file. There is potential abuse of /service/upload servlet in the webmail subsystem. A user can upload executable files (exe,sh,bat,jar) in the Contact section of the mailbox as an avatar image for a contact.

Credit:

The information has been provided by Vendor

The original article can be found at:https://wiki.zimbra.com/wiki/Security_Center


Details

A user will receive a “Corrupt File” error, but the file is still uploaded and stored locally in /opt/zimbra/data/tmp/upload/, leaving it open to possible remote execution.

 

Vulnerable Systems:

Zimbra before 8.8.15 Patch 10

Zimbra 9.x before 9.0.0 Patch 3

 

CVE Information:

CVE-2020-12846

Disclosure Timeline:
Published Date:6/3/2020

Categories: FeaturedNews