‘Apple Webkit Blink Event Dangling Pointer Remote Code Execution Vulnerability’

Summary

This vulnerability allows remote attackers to execute arbitrary code on vulnerable software utilizing Apple’s WebKit library. User interaction is required to exploit this vulnerability in that the target must visit a malicious page.’

Credit:

‘The information has been provided by wushi & Z of team509 .
The original article can be found at: http://www.zerodayinitiative.com/advisories/ZDI-10-031


Details

‘Details:
Vulnerable Systems:

* Apple WebKit

Immune Systems:

N/A

This vulnerability allows remote attackers to execute arbitrary code on vulnerable software utilizing Apple’s WebKit library. User interaction is required to exploit this vulnerability in that the target must visit a malicious page.

The specific flaw exists due to a failure to unregister a callback pointer during the destruction of a particular type of element when embedded inside a ‘blink’ container. The application dereferences the original resource which can can be leveraged by an attacker to execute arbitrary code under the context of the current user.

Patch Availability:

Apple has issued an update to correct this vulnerability. More details can be found at:
http://support.apple.com/kb/HT4070

Workaround:

N/A

CVE Information:

N/A

Disclosure Timeline:

2009-10-27 – Vulnerability reported to vendor
2010-03-16 – Coordinated public release of advisory’

Categories: UNIX