‘Hewlett-Packard Data Protector Express PrvRecvRqu Denial of Service Vulnerability’

Summary

This vulnerability allows remote attackers to trigger a denial of service condition on vulnerable installations of Hewlett-Packard Data Protector.’

Credit:

‘The information has been provided by AbdulAziz Harir.
The original article can be found at: http://www.zerodayinitiative.com/advisories/ZDI-10-175/


Details

Vulnerable Systems:
 * Hewlett-Packard OpenView Data Protector

Authentication is not required to exploit this vulnerability.

The specific flaw exists within the function PrvRecvRqu() defined in the module dpwinsup. While handling requests sent to TCP port 3817 the process can be forced to dereference a NULL pointer resulting in an unhandled exception that crashes the service.

Patch Availability:
Hewlett-Packard has issued an update to correct this vulnerability. More details can be found at:
http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c02067559

CVE Information:
CVE-2010-3008

Disclosure Timeline:
2009-10-21 – Vulnerability reported to vendor
2010-09-13 – Coordinated public release of advisory’

Categories: UNIX