‘HP OpenView Network Node Manager nnmRptConfig.exe Code Execution Vulnerability’

Summary

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of HP Network Node Manager.’

Credit:

‘The information has been provided by Aniway.
The original article can be found at: http://www.zerodayinitiative.com/advisories/ZDI-11-012/


Details

Vulnerable Systems:
 * Hewlett-Packard OpenView Network Node Manager

The specific flaw exists within nnmRptConfig.exe CGI which is exposed by the webserver which listens by default on TCP port 80. When parsing an invalid template name the application uses user supplied data as a format specifier during creation of an error message. An attacker can exploit this vulnerability by supplying a specially crafted and invalid template name to execute arbitrary code under the context of the user.

Patch Availability:
Hewlett-Packard has issued an update to correct this vulnerability. More details can be found at
http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c02670501

CVE Information:
CVE-2011-0270

Disclosure Timeline:
2010-09-22 – Vulnerability reported to vendor
2011-01-10 – Coordinated public release of advisory’

Categories: Windows