‘HP OpenView Network Node Manager ovutil.dll stringToSeconds Code Execution Vulnerability’

Summary

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Hewlett-Packard OpenView Network Node Manager.’

Credit:

‘The original article can be found at: http://www.zerodayinitiative.com/advisories/ZDI-11-004/


Details

Vulnerable Systems:
 * Hewlett-Packard OpenView Network Node Manager

Authentication is not required to exploit this vulnerability. The exploit would require a crafted HTTP request to the target host.

The specific flaw exists within the ovutil.dll module which is loaded by the ovwebsnmpsrv.exe process which in turn can be reached remotely through the jovgraph.exe CGI program. By supplying overly large values to variables passed through an HTTP request a sscanf can be made to overflow a static buffer. An attacker can leverage this to execute arbitrary code under the context of the user running the webserver.

Patch Availability:
Hewlett-Packard has issued an update to correct this vulnerability. More details can be found at http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c02670501

CVE Information:
CVE-2011-0262

Disclosure Timeline:
2010-09-14 – Vulnerability reported to vendor
2011-01-10 – Coordinated public release of advisory’

Categories: Windows