Microsoft ASP.NET MVC Cross Site Scripting Vulnerabilities

Summary

Cross-site scripting (XSS) vulnerability in System.Web.Mvc.dll in Microsoft ASP.NET Model View Controller (MVC) 2.0 through 5.1 allows remote attackers to inject arbitrary web script or HTML via a crafted web page, aka ‘MVC XSS Vulnerability.’

Credit:

Details

Vulnerable Systems:
 * Microsoft ASP.NET Model View Controller (MVC) 2.0 through 5.1

Immune Systems:
 * Microsoft ASP.NET Model View Controller (MVC) after 5.1

Microsoft ASP.NET MVC is prone to a cross-site scripting vulnerability because it fails to properly encode user-supplied input. An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This could allow the attacker to gain elevated privileges.

CVE Information:
CVE-2014-4075

Disclosure Timeline:
Original release date: 10/15/2014
Last revised: 10/31/2014

Categories: Windows